现在的位置: 首页 > 移动开发 > 正文

使用Vundle管理配置Vim的插件

2017年09月17日 移动开发 ⁄ 共 1510字 ⁄ 字号 暂无评论

1、介绍:

安装需要Git,触发git clone,默认将每一个指定特定格式插件的仓库复制到~/.vim/bundle/. 搜索需要Curl支持。

Windows用户请直接访问Windows setup。如果有任何问题,请参考FAQ。查看Tips获取相关高级配置。

使用non-POSIX shells,比如比较流行对 Fish shell,需要额外对步骤。请查看FAQ

2、初始安装Vundle:

git clone https://github.com/VundleVim/Vundle.vim.git ~/.vim/bundle/Vundle.vim

3、配置插件 :

请将以下加在.vimrc方可使用Vundle。删掉你不需要的插件,这些只是用做示例。

vim ~/.vimrc

输入以下内容

set nocompatible              " 去除VI一致性,必须
filetype off                  " 必须

" 设置包括vundle和初始化相关的runtime path
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" 另一种选择, 指定一个vundle安装插件的路径
"call vundle#begin('~/some/path/here')

" 让vundle管理插件版本,必须
Plugin 'VundleVim/Vundle.vim'

" 你的所有插件需要在下面这行之前
call vundle#end()            " 必须
filetype plugin indent on    " 必须 加载vim自带和插件相应的语法和文件类型相关脚本
" 忽视插件改变缩进,可以使用以下替代:
"filetype plugin on
"
" 简要帮助文档
" :PluginList       - 列出所有已配置的插件
" :PluginInstall    - 安装插件,追加 `!` 用以更新或使用 :PluginUpdate
" :PluginSearch foo - 搜索 foo ; 追加 `!` 清除本地缓存
" :PluginClean      - 清除未使用插件,需要确认; 追加 `!` 自动批准移除未使用插件
"
" 查阅 :h vundle 获取更多细节和wiki以及FAQ
" 将你自己对非插件片段放在这行之后

4、安装插件:

运行vim再运行

给我留言

您必须 [ 登录 ] 才能发表留言!